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View all FAQs about Project Deployment and End-user Installation
Dynamic Web TWAIN Service installation and uninstallation issue
Symptom
The old version of Dynamic Web TWAIN Service (also called “Dynamsoft Service”) cannot be uninstalled successfully through the Control Panel, and the new version of Dynamic Web TWAIN Service cannot be successfully installed by double-clicking, or the following error message appears during installation.
Cause
The current user account does not match the user account under C:\Users{account}
In the screenshot below, the current user is owen_thinkpad_t480s, but in ‘Command Prompt’, the corresponding folder under the C:\Users is ThinkPad.
When installing by double-clicking DynamsoftServiceSetup.msi (from v19.0+, use DynamicWebTWAINServiceSetup.msi) or uninstalling via Control Panel, Dynamic Web TWAIN takes the current user’s Temp directory: C:\Users\owen_thinkpad_t480s\AppData\Local\Temp, because this path can’t be found, the installation/uninstallation failed.
Resolution
Run ‘Command Prompt’ as administrator, go to C:\WINDOWS\system32, then execute the following line to uninstall it:
wmic product where name="Dynamsoft Service" call uninstall /nointeractive
//from v19.0+
wmic product where name="Dynamic Web TWAIN Service" call uninstall /nointeractive
and then run the following command to install Dynamic Web TWAIN Service.
msiexec /i "/path/to/DynamsoftServiceSetup.msi" /qn
//from v19.0+
msiexec /i "/path/to/DynamicWebTWAINServiceSetup.msi" /qn